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HANDS  



WHAT IS “BREKEL HANDS” 

 

 

“Brekel Hands” is a Windows application that enables 3D animators to record hand&finger Motion Capture 

data using a Leap Motion sensor. 

 

It is written by Jasper Brekelmans, so in case you’re wondering that’s what “Brekel” refers to. 

“Brekel” is pronounced as “Break–uhl”.  



REQUIREMENTS 

 

- Leap Motion sensor 

- Leap Motion drivers/SDK v2.x or above 

- Microsoft Windows 7 or higher 

- Core i3, i5 or i7 CPU 

- USB 2.0 (or 3.0) port 

- 4 GB RAM or more 

- Graphics card with OpenGL support 

  



LICENSING 

 

With your purchase you should have received a download link for the retail version of the software and an 

email with your license code. (Please allow up to 24 hours for processing your request and double check your 

spam filter) 

 

The retail version will work immediately and with no restrictions even without a valid license, but will need 

activation within 5 days for continuous operation. 

 

You can activate your copy by using the “File > Install License” option from the menu. 

 

 

It will ask you to browse for your license file (which was attached to the mail). 

The license will automatically be copied to your “C:\ProgramData” folder and be active upon restart of the 

application. 

 

To display the current license info use the “File > Show License Info” option from the menu to display a 

window like the following: 

 

  



THE MAIN INTERFACE 

 

 

The interface is divided in: 

- Top Menu 

- 3D View 

- Settings 

These Settings window can be undocked and turned into a floating window by dragging it from the title bar. 

Double clicking on the taskbar of a floating window will dock it back into the main window. 

The state will automatically be saved on exit and reloaded on start. 

  



TOP MENU 

 

File > Install License 

Installs a new license file, more info in the “Licensing” chapter of this manual. 

 

File > Show License Info 

Displays the contents of the currently installed license. 

 

File >  Check for new version on start 

Checks if a new version is available by accessing the brekel.com website. 

 

File > Exit 

Exists the program. 

 

Window > Restore to default 

Restores the interface to the default state, including showing hidden windows. 

 

Window > Draw FPS 

Toggles drawing of tracking and drawing FPS at the bottom of the 3D view. 

 

Window > Draw Memory/CPU usage 

Toggles drawing of the memory and CPU usage at the bottom of the 3D view 

  



Help > Driver Installation 

Opens a webpage describing how to install the drivers. 

 

Help > Downloads Page 

Opens the download page with current and previous versions. 

 

Help > Forum 

Opens a webpage with the user forum. 

 

  



THE 3D VIEW 

 

 

 

The main area displays all the 3D tracking data. 

 

When the “Live” tab is selected it will show live tracking data coming from the sensor. 

When the “Preview” tab is selected the last recorded take will be shown. 

 

For navigation: 

- Left mouse button for orbit 

- Middle mouse button for dolly 

- Right mouse button for drag 

- Mouse wheel for dolly 

 

  



Table 

This will draw a grid underneath the sensor in the 3D view, visualizing the table. 

 

Interaction Box 

This will draw a brown box in the 3D view roughly indicating the area in which hands & fingers can be tracked. 

 

Wireframe 

This will draw the hand palms as circles and fingers as lines. 

 

Axis 

This will draw a small axis for each palm and each finger joint. 

Red represents the X axis, Green the Y axis and Blue the Z axis, these can be adjusted to exactly match your 

character rig on the “Axis Setup” tab in the “Settings” area. 

 

Hand Info 

This will display additional info for each hand, like Left/Right, Grab and Pinch percentages and the tracking 

Confidence. 

 

Finger Lengths 

This will display the length of each finger in the 3D view. 

 

Finger Widths 

This will display the width of each finger in the 3D view. 

  



Memory 

Indicates how much overall system memory is in use. (by all running applications) 

 

CPU 

Indicates how much overall CPU power is in use. (by all running applications) 

 

Tracking FPS 

Indicates at how many frames per second the tracker is running. 

 

Drawing FPS 

Indicates how fast the 3D drawing is running, note that if this is lower than the tracking FPS no data is dropped 

when recorded to files or streamed  across the network. 

  



SMOOTHING 

  

 

Every vison-based tracking solution inherently contains noise so it’s usually a good idea to perform a little bit 

of smoothing/filtering. Generally you want to apply more smoothing to the hands than the fingers to preserve 

detail. 

 

Palms 

Toggles hand palm smoothing on/off. 

 

Fingers 

Toggles finger smoothing on/off, 

 

Strength 

Amount of smoothing to apply, higher values mean smoother data but also increase lag. 

 

Responsiveness 

Increasing this can bring back more sharpness during quick motions while preserving smoothness for slower 

motions. 

  



AXIS SETUP 

 

 

In order to make connecting your character rig to the recorded data as easy as possibly it’s a good idea to 

match their coordinate systems. 

Using the Axis settings you can align the tracker so it matches your rig, look at the Axis visualization in the 3D 

view and match your rig. 

Different settings for each hand are possible depending on how your rig is mirrored (or not). 

 

Left/Right Hand Forward > X Y Z 

Specifies the axis that points along the fingers to be either X (Red), Y (Green) or Z (Blue). 

 

Left/Right Hand Forward > Flip 

When ON the positive side of the selected X/Y/Z axis points along the finger, when OFF the negative side 

points along the finger. 

 

Left/Right Hand Up > XYZ 

Specifies the remaining axis that points up, away from the palm. 

 

Left/Hand Up > Flip 

When ON the positive side of the selected axis points away from the palm, when OFF the negative side. 

  



NETWORK 

 

Protocol 

Selects either TCP/IP or UDP as the streaming protocol, or turns streaming off. 

 

Port 

The network port used for streaming the data (default 8876) 

Make sure your firewall isn’t blocking this! 

 

State 

The current state of the network streaming, depicts if there are any clients connected or any errors. 

 

  



Record Triggering 

Allows synchronized recording across multiple Brekel applications. 

One application can be in Primary mode, all others in Secondary or Ignore mode. 

The Primary application will send a signal when recording is started and stopped so all applications start/stop 

at the same time and are using matching filenames. 

Note that this works across multiple apps on the same machine and even across multiple machines on the 

same network. 

 

Make sure your firewall isn’t blocking port 8880-8890. 

 

 

OSC 

Enable/disable sending data out over UDP in OSC (Open Sound Control) format. 

See chapter at the end of this manual for a description of the OSC messages that are sent. 

 

Coordinates 

Specifies whether to send global or local coordinates over the OSC port. 

 

Host 

Hostname / IP of machine to send the OSC data to (localhost if receiving application is running on the same 

machine as the Brekel application). 

 

Port 

Network port over which to send the OSC data.  



OUTPUT FORMATS 

 

FBX 

FBX files are the preferred format since they can contain a 100% accurate representation of the tracking data, 

and should be supported by most 3D applications. 

 

Resample Frame Rate 

Specifies at which framerate the raw data should be resampled. 

 

You can switch between V7.3 and V6.1 of the file format in case your FBX importer only supports an older 

format. 

 

Include Body 

When disabled a hierarchy of 2 hands (just like in the 3D view window) will be exported. With 

position/rotation for the hand and rotations for each finger joint. 

When enabled a static full body skeleton with rotation data for the fingers will be exported. 

Depending on your character rig and preferences you may find one or the other more convenient to work ith. 

 



BVH 

BVH is a common, yet 20 year old skeleton format supported by some 3D applications. 

Note that the format is not as accurate as FBX since it can’t contain custom axis configurations, nor can it hold 

small interframe timing fluctuations. 

Also some BVH importers in various 3D apps work better than others, and some are not designed to handle 

fingers at all. 

 

You can select BVH variations for MotionBuilder/HumanIK, 3DMax Biped and Poser/DAZ. This will internally 

match the default bone-naming template as well as basepose. 

 

Include Body 

When disabled a hierarchy of 2 hands (just like in the 3D view window) will be exported. With 

position/rotation for the hand and rotations for each finger joint. 

When enabled a static full body skeleton with rotation data for the fingers will be exported. 

Depending on your character rig and preferences you may find one or the other more convenient to work 

with. 

 

TXT 

Saves all the data in a readable text format. 

For example in case you want to write a custom importer to interpret and use the data. 

 

CSV 

Writes to a Comma Separated Values file containing angles for the joints. 

This could for example be used to analyze the data in a spreadsheet. 

  



RECORDING 

 

Output Filename 

The name of the output file(s), note that the output folders can be specified for each format individually 

 

Auto Filename 

When turned ON the filename will be automatically generated using the current date & time. 

 

Start Delay (in secs) 

When bigger than 0 a countdown will start after starting a recording, giving you a few seconds to get into 

position before capture will start. 

During countdown there will be beeps played over the speakers every second, and the amount of remaining 

seconds will also be shown visually in the 3D window. 

 

Preview after record 

When turned ON the 3D view will automatically swap to the “Preview” tab and display the last recorded file. 

When turned OFF it will stay on the “Live” tab but you still have the option to manually switch to the 

“Preview” tab and look at the last recording. 

 

Start/Stop Recording 

Toggle button for starting & stopping the recording. (Note the button turns red while recording) 

  



PREVIEW 

 

When switching the 3D view to the Preview tab it will display the last recorded take instead of live data from 

the sensor. 

You can play/pause/scrub trough the data using the standard video player and slider controls. 

 

Delete Take 

Will delete the recorded data from disk. 

 

Keep Take 

Will keep the recorded data and switch back to streaming Live data. 

(Note, this is the same as simply switching back to the Live tab manually) 

 

 

  



SENSOR PLACEMENT 

 

 

 

Normally you want to place the Leap Motion device flat on a table with your hands hovering above it. 

 

Note that there is a setting in the Leap Motion Control Panel that optimizes the tracker for top-down use, but 

due to finger visibility this may not work as well. 

 

  



MOTIONBUILDER PLUGIN INSTALLATION 

The installer should have automatically installed the plugins for the available versions of MotionBuilder. 

And you should now have a “Brekel Pro Hands” Device listed under the “Devices” folder of the “Asset 

Browser”. 

 

 

If it doesn’t show up, you can find all the plugins for the various MotionBuilder versions (2009-2015 both 32- 

and 64 bit) in the “Brekel Pro Hands” installation folder, usually in: 

C:\Program Files\Brekel Pro Hands\MotionBuilder plugins 

 

Simply copy the .dll file of your particular MotionBuilder version to it’s plugin folder. 

Typically for a 32 bit version: 

C:\Program Files (x86)\Autodesk\MotionBuilder 2013\bin\win32\plugins 

 

For a 64 bit version: 

 C:\Program Files\Autodesk\MotionBuilder 2013\bin\x64\plugins 

  



USING THE MOTIONBUILDER PLUGIN 

 

First make sure “Brekel Pro Hands” is running. 

 

To setup a MotionBuilder scene go through the following steps: 

- drag a “Brekel Pro Hands” Device from the “Devices” folder in the “Asset Browser” into your scene. 

- In the GUI for the device make sure the “Hostname/IP” points to the machine running the          

“Brekel Pro Hands” application. This can either be a separate machine that is reachable over a 

network connection or the same machine. 

- (Note: if both applications are running on the same machine you can simply use the default 

Hostname/IP of “127.0.0.1”) 

- Toggle the “Online” button to turn the device on 

- Under “Model binding:” hit the “None” option and then “Create”, this will create a model hierarchy in 

your scene containing the skeletons 

  



Hostname/IP 

Should point to the machine running Brekel Pro Hands. 

If both MotionBuilder and Pro Hands run on the same machine you can also leave this at the default of 

localhost or 127.0.0.1 

 

Port 

Should be the same port as used in the Brekel Pro Hands application. (default 8876) 

 

Protocol 

Should be the same protocol (TCP/IP or UDP) as used in the Brekel Pro Hands application. 

 

  



To record a sequence: 

- Make sure “Online” on the device is toggled ON 

- Make sure “Live” on the device is toggled ON 

- Make sure “Recording” on the device is toggled ON 

- Make sure the “Record” button on the timeline transport controls is toggled ON 

- Hit the Play button, and Stop button once the action is over 

 

To play back a recording: 

- Make sure “Online” on the device is toggled ON 

- Make sure “Live” on the device is toggled OFF 

- Hit Play on the timeline transport controls or scrub trough the timeline 

  



OSC (OPEN SOUND CONTROL) MESSAGES 

 

The following messages are sent:  

 

 

Address pattern: /hand_L (or /hand_R) 

int: ID of the hand 

int: forward axis  0=X 1=Y 2=Z 

int: up axis   0=X 1=Y 2=Z 

bool: flip forward  is forward axis reversed or not 

bool: up forward  is up axis reversed or not 

float: timestamp 

float: tracking confidence 0.0 not confident - 1.0 fully confident 

float: grab strength 

float: pinch strength 

float: palm width 

float: arm width 

 

 

Address pattern: /elbow_L (or /elbow_R) 

int: ID of the hand it belongs to 

float: X position in global space 

float: Y position in global space 

float: Z position in global space 

float: X rotation in global space and in euler angles 

float: Y rotation in global space and in euler angles 

float: Z rotation in global space and in euler angles 

 

  



Address pattern: /wrist_L (or /wrist_R) 

int: ID of the hand it belongs to 

float: X position 

float: Y position 

float: Z position 

float: X rotation in euler angles 

float: Y rotation in euler angles 

float: Z rotation in euler angles 

 

Note that the "OSC Coordinates" setting in GUI depicts if these are in global coordinates (relative to sensor) or 

local coordinates (relative to parent joint) 

 

 

Address pattern: / palm_L (or / palm_R) 

int: ID of the hand it belongs to 

float: X position 

float: Y position 

float: Z position 

float: X rotation in euler angles 

float: Y rotation in euler angles 

float: Z rotation in euler angles 

float: X palm velocity 

float: Y palm velocity 

float: Z palm velocity 

 

Note that the "OSC Coordinates" setting in GUI depicts if these are in global coordinates (relative to sensor) or 

local coordinates (relative to parent joint) 

  



Address pattern: /<fingerName>_base_L (or /<fingerName>_base_R) 

(see list below for possible fingerName) 

int: ID of the hand it belongs to 

float: finger length 

float: finger width 

float: X position 

float: Y position 

float: Z position 

float: X rotation in euler angles 

float: Y rotation in euler angles 

float: Z rotation in euler angles 

 

Note that the "OSC Coordinates" setting in GUI depicts if these are in global coordinates (relative to sensor) or 

local coordinates (relative to parent joint) 

 

 

Address pattern: /<fingerName>_knuckle1_L (or /<fingerName>_ knuckle1_R) 

(see list below for possible fingerName) 

int: ID of the hand it belongs to 

float: X position 

float: Y position 

float: Z position 

float: X rotation in euler angles 

float: Y rotation in euler angles 

float: Z rotation in euler angles 

 

Note that the "OSC Coordinates" setting in GUI depicts if these are in global coordinates (relative to sensor) or 

local coordinates (relative to parent joint) 

  



Address pattern: /<fingerName>_knuckle2_L (or /<fingerName>_ knuckle2_R) 

(see list below for possible fingerName) 

int: ID of the hand it belongs to 

float: X position 

float: Y position 

float: Z position 

float: X rotation in euler angles 

float: Y rotation in euler angles 

float: Z rotation in euler angles 

 

Note that the "OSC Coordinates" setting in GUI depicts if these are in global coordinates (relative to sensor) or 

local coordinates (relative to parent joint) 

 

 

Address pattern: /<fingerName>_tip_L (or /<fingerName>_ tip_R) 

(see list below for possible fingerName) 

int: ID of the hand it belongs to 

float: X position 

float: Y position 

float: Z position 

float: X rotation in euler angles 

float: Y rotation in euler angles 

float: Z rotation in euler angles 

float: X palm velocity 

float: Y palm velocity 

float: Z palm velocity 

 

Note that the "OSC Coordinates" setting in GUI depicts if these are in global coordinates (relative to sensor) or 

local coordinates (relative to parent joint) 

 

  



Available joint names for <fingerNames> 

thumb 

index 

middle 

ring 

pinky 

 


